Impossible de connecter biblio NAS


Badge
Bonjour,

J'essaye de connecter mon SONOS CONNECT à une bibliothèque musicale sur un NAS.
Je suis sous Windows 10.
Avec l'explorateur Windows je me connecte bien à tous mes répertoires, mais quand je veux ajouter le chemin dans la boîte de dialogue SONOS avec le nom d'utilisateur et le bon mot de passe, il produit le message suivant :
"Sonos n'a pu ajouter le dossier musical"

J'ai essayé de résoudre le problème avec l'aide normale mais les menus décrits ne correspondent pas à ma version e Windows 10.....

Quelqu'un a t'il une idée ?

15 Commentaires

Badge
Salut,

depuis hier soir je cherche une solution a ton problème.
Comme j'ai aussi un nas, c'était facile pour tester.
Maintenant j'avais pas tout a fait le meme message d'erreur.

1 ton antivirus et le firewall doit laisser Sonos sortir de ton PC.
2 Qu'elle est la marque de ton Nas et le model?
J'ai remarquer que Sonos ne prend pas en compte le SMB 2 ou 3, j'ai du changer les paramètres de mon nas en SMB1.
3 le compte utilisateur que tu utilises doit avoir les droits sur le dossier.
4 peux tu mettre IP et pas le nom stp pour voir si tu as le meme message.

Tu vas trouvé ton message d'erreur la
http://sonos-fr.custhelp.com/app/answers/detail/a_id/3457/~/résolution-des-problèmes-de-la-bibliothèque-musicale#content

Tu n'as peut être pas les droit de lire le dossier.


@ Sonos merci de mettre la documentation a jours il faut du SMB 1 avec erreur 900.
Peut être cela serait bien de faire un update SMB... en sachant que le SMB1 est vulnérable .....
Bulletin de Microsoft MS17-10 je le connait bien pour le travail^^
https://technet.microsoft.com/en-us/library/security/ms17-010.aspx


Brian
Badge
Bonjour,

Mon NAS est un SYNOLOGY DS214 play.
Windows voit bien le SONOS mais je ne peux même pas lancer de musique dessus en cliquant droit sur un morceau !

Comment mettre le SONOS en SMB 1 ?
Badge
Bonsoir,

pour verifier la norme SMB que tu utilises tu dois aller dans le panneau de configuration dans le DSM.
Puis Services de fichiers puis tu as SMB et la tu vas dans paramètres avancés.
Protocole SMB minimum tu dois mettre SMB1.

Dans ton dernier message tu indiques que windows voit bien le sonos mais tu ne peux pas lire la musique ?


Brian
Badge
Bonjour,

@Brian, mon SMB est mini SMB1, maxi SMB 2.
Pour ce qui concerne le SONOS voici ce que voit l'explorer:



Et si je fais cela :




Eh bien cela marche (cette fois-ci mais la précédente, non ! ), je peux écouter le morceau choisi.
Et après vérification je ne peux toujours pas enregistrer la bibliothèque !

Pour tes questions précédentes, j'ai lu les différentes rubriques du support mais ça n'a pas résolu mon problème....
Mon compte utilisateur a les droits sur le fichier.
Et en mettant l'adresse IP au lieu du nom :



Marc
Badge
Bonjour Marc,

le chemin que tu donnes a Sonos c'est //192.168.0.19/..../divers
C'est bien IP du nas?
Parce que su la 2 em photos c'est marquer sonos Connect Avec ip du Connect.
Parce que la je me demande si tu ne donnes pas une mauvaise ip.
Tu dois connecter ton nas a application sonos.

Peux tu donner ip de ton nas et ip du sonos Connect

Brian
Badge
Brian,

L'IP du NAS c'est 192.168.0.13 et celle du SONOS c'est 192.168.0.19



Marc
Badge
Marc,


donc oui tu dois bien mettre Ip du nas //192.168.0.13/music
Effectivement si toute ta musique ce trouve la.
Ce qui veut dire que tu as installer le package serveur multimédia.
Tu dois bien vérifier dans panneau de configuration ,Utilisateur, puis modifier , onglet permission , que utilisateur a bien les permissions.
Je te recommande meme de crééer un utilisateur exemple sonos .
Que tu donnes les droits au dossier music seulement et rien d'autre.
En informatique toujours mieux prévoir que guérir.

Si cela fonctionne toujours pas.
Peut être désactiver le firewall du nas.
Tu testes comme cela.
Si cela fonctionne cela vient de la, sinon je dois encore réfléchir XD

Brian
Badge
Bonsoir Brian,

Voilà, j'ai juste suivi tes conseils...
J'ai créé un utilisateur SONOS avec des droits sur le dossier "music" de mon SYNOLOGY.
et j’ai pu ajouter ma bibliothèque !
Et ça fonctionne !

Merci
- pour ta patience,
- tes explications pas à pas
- et la justesse de celles-ci
- de permettre à quelqu'un comme moi de réussir à remettre en route le SONOS avec le nécessaire !

Bien cordialement,
Marc
Badge
Bonsoir Marc,

je suis content pour toi.
Avec plaisir c'est mon job.
Donc l'utilisateur que tu as utilisé avant n'avais pas les droits.
Sur ton nas je te conseilles d'utiliser plusieurs utilisateurs.
Un pour ton sonos. un autre pour tes films avec dsvideo, question de sécurité.

Bien vérifier que ton firewall est actif. avec les bon ports actif.
Dans les packages a installer tu as un antivirus gratuit tu peux le mettre et faire des analyses automatique.

Et le plus important appliquer les updates de syno, j'ai fait une update ce matin pour la sécurité du syno.

Bonne musique avec ton Connect.

Brian
Badge
Brian,

Brian5542 a écrit:


Sur ton nas je te conseilles d'utiliser plusieurs utilisateurs.
Un pour ton sonos. un autre pour tes films avec dsvideo, question de sécurité.


Maintenant j'ai compris comment faire ! :D

Brian5542 a écrit:


Bien vérifier que ton firewall est actif. avec les bon ports actif.


Parle tu de celui du SYNOLOGY ?
Qu'appelle tu "les bons ports actifs" ?
As-tu un (ou des) exemple(s) à me donner ou un lien utile pour m'aider ?

Brian5542 a écrit:


Dans les packages a installer tu as un antivirus gratuit tu peux le mettre et faire des analyses automatique.
Brian


Je vais voir comment faire.

Brian5542 a écrit:


Et le plus important appliquer les updates de syno, j'ai fait une update ce matin pour la sécurité du syno.
Brian


Je l'ai fait aujourd'hui aussi !

Et pour la bonne musique c'est déjà en route :8
Badge
Marc,

pour le firewall oui celui du syno, tu dois aller panneau de config , sécurité. onglet pare feu.
il doit être actif.
Si tu utilises ton nas juste a la maison et que tu ne te connectes pas à distance quand tu n'es pas chez toi, tu ne dois pas ouvrir tout les ports comme moi.
Comme regarder un film ou écouté de la musique.


Pour antivirus cela est dans package. sécurité (voir la photo).

voir les pièces joints.

Brian
Badge
Bonjour Brian,

J'ai activé le pare-feu mais maintenant il faut que j'ouvre des ports comme sur ton annexe 1 afin de communiquer depuis l'extérieur car j'utilise beaucoup DS File et DS Photo.
Comment y arriver ?

Pour l'anti-virus, j'ai vu que tu utilisait Mac Afee. Dans le passé, même au boulot ce n'était pas satisfaisant... !
As-tu essayé les 3 autres (Synology et HASP ?

J'ai configuré le reste comme tu l'as indiqué dans tes captures d'écran.

Marc
Badge
Bonjour Marc,

pour antivirus oui effectivement j'utilise Mcafee. c'était au début donc il y a plus de 3 ou 4 ans quand syno a commencé a proposer le package de mcafee.
Le package Synology essential anti virus de syno est bon il est sur du Clamav qui est un antivirus open source
https://www.clamav.net

Pour le firewall donc il était pas activé avant?
comment tu fais pour te connecté a distance tu utilises le quickconnect? ou tu as un nom de domaine a toi?
Si tu utilises le quickconnect cela est plus facile pour les débutants.
Tu te connectes par l'adresse du quickconnect.
Apres l'autre manière plus compliqué.
Il faut activer dans le firewall les ports, puis aller dans le routeur et il faut faire du port forwardin.


Brian
Badge
Brian,

Brian5542 a écrit:

Bonjour Marc,

pour antivirus ...
Le package Synology essential anti virus de syno est bon il est sur du Clamav qui est un antivirus open source
https://www.clamav.net



Oui, je connais Clamav ayant touché longtemps à Linux et essayant maintenant BSD.

Brian5542 a écrit:


Pour le firewall donc il était pas activé avant?



Non, il n'était pas activé...

Brian5542 a écrit:


comment tu fais pour te connecté a distance tu utilises le quickconnect? ou tu as un nom de domaine a toi?
Si tu utilises le quickconnect cela est plus facile pour les débutants.
Tu te connectes par l'adresse du quickconnect.



En fait j'ai activé quickconnect et les logiciels DSFile, DSPhoto utilisent le quickconnect id mais utilisent le mot de passe et l'utilisateur admin... ce qui est évidemment assez dangereux !

Brian5542 a écrit:


Apres l'autre manière plus compliqué.
Il faut activer dans le firewall les ports, puis aller dans le routeur et il faut faire du port forwardin.
Brian



Si je peux faire quelque chose de plus sûr et que je puisse reproduire par la suite (un bon tuto !!!! ) je suis prêt à essayer.
Il semblerait qu'il faille ajouter port par port...
Par similitude je peux essayer de reproduire ce qu'il y a sur ton image... mais après ?
Badge
Marc,

je ne connais pas de tuto.
Pour les utilisateurs.
Par défaut je désactive admin du syno après avoir créée un autre utilisateur admin du nas. que je vais pas nommer admin ou administrateur évidemment.
J'ai un utilisateur standard pour dsfile, un autre pour les video. ou un autre pour les cameras.
Tout depend de ce que tu fais avec ton nas. Mais il faut bien faire les permissions des dossiers pour chaque utilisateurs.
Par exemple utilisateur Video peut juste aller dans video, pas des les autres répertoires.

Grace au quickconnect si je me trompe pas tu ne dois pas ouvrir les ports. tout passe par Synology.
Donc tu ne dois pas activer des ports dans le firewall ou ton routeur. plus facile comme cela.


Dans ton firewall je te donne un exemple de ce que j'ai fait:

Tu peux refuser 15 pays max par règles qui ne peuvent pas se connecté au nas depuis internet.
Evidemment si tu prends Espagne, quand tu vas en vacances tu ne pourras pas te connecter :)




la tu peux activer un port par défaut pour te connecter directement a file station ou video avec ordinateur.




J'espere que cela peut déjà t'aider.


Brian

Commenter

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)