Problème Android de stabilité WiFi avec la mise à jour 8.1


Niveau d'utilisateur 2
Badge
J'ouvre une autre conversation sur cet autre problème lié à la mise à jour 8.1 (voir https://fr.community.sonos.com/installation-et-fonctionnement-229100/mise-a-jour-8-1-foireuse-resolue-6766241 pour la partie infrastructure).

Depuis la mise à jour 8.1, le WiFi de mes Android est devenu instable. Qu'il soit configuré en 2.4 GHz ou en 5 GHz, l'usage de l'application Sonos provoque déconnexion du WiFi, ou perte de la connectivité internet (le WiFi est détecté comme sans accès à internet, alors qu'il fonctionne parfaitement depuis un PC).

Parfois, c'est le lancement d'une musique qui provoque le problème. Autre symptome observé: impossible de se connecter au lecteur plusieurs fois de suite, pièce qui affiche "pas de musique" alors que le haut-parleur fonctionne, ou morceau présenté sur l'écran différent de celui joué.

Lorsque l'application Sonos est désinstallée, le WiFi fonctionne normalement.

30 Commentaires

Niveau d'utilisateur 2
Badge
Bon, nouveau bug ce soir: une pièce a disparu de l'application... Et pourtant elle continue de jouer ! Bon, au bout de cinq minutes elle est réapparue...
Niveau d'utilisateur 2
Badge +2
Bonjour. Sur quel type d'appareil Android rencontrez vous des difficultés? Pourriez vous nous faire parvenir un diagnostic?
https://sonos-fr.custhelp.com/app/answers/detail/a_id/2476
Niveau d'utilisateur 2
Badge
Bonsoir,

Voici le message que j'obtiens en essayant de faire un diagnostic...
😠
Niveau d'utilisateur 2
Badge
J'ai réinitialisé les contrôleurs Sonos plusieurs fois. Ils sont sous Android 7.0 (Galaxy A5) et Android 8.0.0 (Nexus 5X) en version 8.1.1. J'ai changé le canal SonosNet en utilisant le diagnostic de la Box pour éviter les canaux trop utilisés.
Niveau d'utilisateur 2
Badge
Finalement, à force d'essayer, le numéro de diagnostic est le 8051644
Niveau d'utilisateur 2
Badge
Bonjour. Sur quel type d'appareil Android rencontrez vous des difficultés? Pourriez vous nous faire parvenir un diagnostic?
https://sonos-fr.custhelp.com/app/answers/detail/a_id/2476


Bonjour Arnaud,

Pour information, j'ai aussi une discussion en cours sur le forum anglophone (https://en.community.sonos.com/troubleshooting-228999/8-1-update-completely-unstable-and-broken-6793707/index1.html#post16164335).

Je continue mes tests et en voici la synthèse:
- Android 6.0.1 on Nexus 7 with Security patch level 2016: apparently no disconnection problem (for the moment, I don't monitor the application reactiveness, only how the WiFi connection behaves)
- Android 7.0 on Samsung Galaxy A5, running Android 7.0 with Samsung Experience 8.1, patched at August 2017 level. WiFi disconnecting intermittendly. Application disconnecting from Sonos.
- Android 8.0.0 on Nexus 5X with October 2017 Security patch level. Application hardly usable. WiFi disconnection. Numerous 1001 errors when trying to launch music, etc.


Je crois vraiment qu'il y a un souci, peut-être lié à ceci:

Android 8.0 Behavior Changes (https://developer.android.com/about/versions/oreo/android-8.0-changes.html#atap)

Seamless Connectivity

Android 8.0 (API level 26) makes a number of improvements to Wi-Fi Settings to make it easier to choose the Wi-Fi network that offers the best user experience. Specific changes include:

Stability and reliability improvements.
A more intuitively readable UI.
A single, consolidated Wi-Fi Preferences menu.
On compatible devices, automatic activation of Wi-Fi when a high quality saved network is nearby.
Niveau d'utilisateur 6
Badge +2
Merci pour ces précisions Florent.
Si certains bugs ont été signalés et identifiés suite à la mise à jour 8.0, puis 8.1, une dégradation de la connexion wifi sur les appareils Android n'en fait pas partie.
Avez-vous sur ces appareils Android activé l'option "se connecter au SonosNet" dans les paramètres avancés de l'application Sonos (fonction permettant à l'appareil de se connecter en direct sur le sous-réseau Sonos, sans passer par votre wifi) ?
Niveau d'utilisateur 2
Badge
Merci pour ces précisions Florent.
Si certains bugs ont été signalés et identifiés suite à la mise à jour 8.0, puis 8.1, une dégradation de la connexion wifi sur les appareils Android n'en fait pas partie.
Avez-vous sur ces appareils Android activé l'option "se connecter au SonosNet" dans les paramètres avancés de l'application Sonos (fonction permettant à l'appareil de se connecter en direct sur le sous-réseau Sonos, sans passer par votre wifi) ?

Non cette option n'est actuellement pas cochée. Il m'est arrivé de l'utilser. Notamment, lorsque je me suis retrouvé coincé sans pouvoir faire de mis à jour (aucune tentative n'aboutissait). J'ai essayé en étant connecté à Sonos Net. J'ai bien sûr été déconnecté lors du reboot des devices, mais la mise à jour est passée.
Niveau d'utilisateur 2
Badge
Finalement, à force d'essayer, le numéro de diagnostic est le 8051644

@Yvain Est-ce que le diagnostic révèle quelque chose de particulier ?
Niveau d'utilisateur 6
Badge +2
Le diagnostic montre quelques problèmes, mais qui ne peuvent pas expliquer une dégradation de la connexion wifi de vos appareils Android.
La pièce "Antonin" notamment ne communique pas bien avec le Bridge et le Bridge lui même a rencontré des problèmes de connexion aux appareils (mais ceci peut correspondre avec les tests de canaux wifi que vous avez effectués, certains des canaux wifi testés étant moins bons que le canal actuel).
Afin de nous assurer que le Bridge ne rencontre pas de problème technique, pourriez-vous temporairement câbler l'une de vos enceintes à sa place (et le laisser débranché le temps du test) : voyez-vous une amélioration ?
Niveau d'utilisateur 2
Badge
Bonjour,

Tout d'abord merci du retour.

Hier soir et ce matin, ô surprise, aucun dysfonctionnement constaté ! Les mêmes téléphones qui posaient problème hier, se retrouvaient stables au niveau Wi-Fi, y compris en surfant sur la bibliothèque musicale, ce qui provoquait quasi systématiquement une déconnexion du WiFi du téléphone la veille au soir.

J'ai donc cherché ce qui avait pu changer. Les seuls point notables:
1. Sur l'Android 8.0 la librairie musicale avait disparu. La réinitialisation du contrôleur l'a fait réapparaître, mais le fonctionnement a continué parfaitement.
2. Sur l'Android Samsung (7.0), le réseau Sonos Net est visible et le téléphone peut s'y connecter, indépendamment du réglage correspondant dans l'interface. Le réseau n'est pas visible sur l'Android 8.0. Mais là encore, pas de changement.
3. La box n'a pas rebooté, mais le service DHCP oui.

J'ai donc vérifié les logs DHCP, mais rien de concluant. Je n'ai pas trouvé de trace de double attribution d'IP qui auraient pu poser problème.

Au niveau WiFi, j'ai refait des scans ce matin. Une box SFR semble désormais positionnée sur le canal 7. La matrice réseau s'avère variable dans le temps.

Je vais laisser tourner quelques temps le système, voir ce soir si tout fonctionne, et refaire un diagnostic. Je reste perplexe, car visiblement il y a de la perturbation WiFi à l'origine du problème, mais une amplification de l'impact sur Android que je ne m'explique pas vraiment. Evidemment, si j'arrive à reproduire le problème, je vous en ferai part.

Cordialement,
Niveau d'utilisateur 6
Badge +2
Merci pour ces infos Florent.
Concernant les changements de canaux wifi, la plupart des box sont malheureusement configurées par défaut pour changer automatiquement de canal : un canal relativement libre à un moment donné peut donc se retrouver congestionné quelques jours plus tard.
N'hésitez pas à revenir vers nous si le problème se pose de nouveau (en effectuant dans ce cas le test de remplacer le Bridge par un autre appareil).
Niveau d'utilisateur 2
Badge
Bonjour,

Petit update. So far, so good, pas de nouveau problème...
Pourtant l'environnement réseau apparaît vraiment chargé 😞 On se demande vraiment comment Sonos s'en sort sur le canal 6 ;-)
J'ai fait deux diagnostics à deux jours d'écart: 8060499 et 8065925.

Pas de reproduction des bugs Android 😕
Niveau d'utilisateur 2
Badge
Malheureusement, la dernière mise à jour semble à nouveau perturber le fonctionnement. Je suis désormais en 8.2 et j'expérimente à nouveau des problèmes de connexion à mon système Sonos depuis l'application Android Sonos.


Diagnostic: 8100409
Niveau d'utilisateur 2
Badge
Petit diagnostic d'environnement: apparemment un autre équipement s'est installée sur le canal 6 :-(

Bascule du Sonos Net sur canal 1... la suite au prochain épisode...
Niveau d'utilisateur 2
Badge
Il semble que le bug Android soit de retour. Nombreuses erreurs 1001 lors de l'accès à la bibliothèque de lecture. A noter qu'Android vient également de publier une mise à jour de sécurité en date du 5 novembre sur 8.0.0. J'ai envoyé un diagnostic via Android également.
Niveau d'utilisateur 5
Badge +3
Salut FlorentBL,

tu n’investirais pas dans une antenne wifi.
Je pense vraiment et je suis vraiment convaincu parce que c'est la même chose en Belgique.
Le wifi des box c'est vraiment pas terrible.
J'avais que des problemes avant.
Maintenant plus aucun probleme.
Meme avec 10 box autour de moi.


Brian
Niveau d'utilisateur 2
Badge
Bonjour Brian,

Etant dans une configuration Bridge + Sonos Net, je ne vois pas trop ce que cela changerait. Le système n'utilise pas du tout le réseau WiFi de la box. Il est connecté par câble et sur un canal différent.
Mais, je vais quand même essayer avec l'accès WiFi de ma Time Capsule, pour voir si cela change quelque chose, parce que c'est super pénible.
Niveau d'utilisateur 2
Badge
Testé avec une autre borne WiFi et sans changement. 😠
Niveau d'utilisateur 2
Badge
Il semble qu'une nouvelle mise à jour soit disponible sur Play Store... on va essayer...
Niveau d'utilisateur 2
Badge
Contrôleur Android en version 8.2.1... pas de réel changement... le contrôleur continue de perdre régulièrement la connexion avec le système. 😞
Niveau d'utilisateur 2
Badge
Par contre, le widget fonctionne à nouveau, c'est déjà ça :8
Niveau d'utilisateur 6
Badge +2
@FlorentBL : avez-vous pu tester le fonctionnement du système avec un autre appareil que le Bridge (par ex. l'un de vos deux Play:1) câblé à votre box internet ?
Testé ce soir en désespoir de cause. Play 1 connecté à la Box. Comportement identique du contrôleur Sonos 8.2.1 sur Android 8.0.0 avec mise à jour de sécurité du 5/11/2017.
Ah oui, j'ai dû aussi me créer un nouveau compte de communauté ! Il semble que le lien avec FlorentBL ait été perdu : le site me demandait de créer un pseudo et refusait FlorentBL comme déjà utilisé...

Commenter