Question

Version Android


Bonjour,
J'ai reçu un message indiquant que Sonos a dorénavant besoin de la version d'Android 4.3 minimum. Or sur ma tablette Samsung SM-T110, c'est seulement la version 4.2.2. Est-il possible d'upgrades la tablette ? Sinon, cela signifie-t-il que je ne peux plus utiliser Sonos sur cette tablette ?

14 Commentaires

Niveau d'utilisateur 5
Badge +3
Bonjour Emmanuel,

Pour vérifier s'il y a une mise à jour de disponible vous devez aller dans:

Paramètres - À propos du périphérique - Mise à jour logicielle- Vérifier mise à jour

Les termes que j'ai écris ci-dessus peuvent être légèrement différents sur votre appareil.
Merci, j'ai essayé mais le système me dit que toutes les mises à jour sont faites, mais je suis toujours en 4.2.2.
Niveau d'utilisateur 5
Badge +3
Cela indique donc que Samsung ne supporte plus votre tablette, vous ne pourrez alors plus l'utiliser pour votre système Sonos.

Vous n'êtes pas le premier qui se retrouve dans cette situation, le sujet revient à chaque mise à jour se Sonos. Malheureusement, Sonos ne peut supporter un produit qui n'est plus supporté par son propre fabricant.
Niveau d'utilisateur 2
Même problème ! Impossible de modifier la version Android de ma tablette Samsung... et depuis la nouvelle mise à jour Sonos 8.3 mon système est tout à coup "obsolète" alors qu'il fonctionnait très bien avec la version 8.2 ! Je trouve inadmissible que Sonos ne nous permette pas de télécharger une version antérieure qui était fonctionnelle avec notre appareil mobile (téléphone intelligent et/ou tablette). Il y aurait dû y avoir une mise en garde importante concernant cette mise à jour afin de nous donner le choix de la faire ou non.
Niveau d'utilisateur 5
Badge +3
J'imagine que techniquement Sonos ne peut supporter à la fois un ancien système (Android, Apple ou Windows) et un nouveau.

Ce serait bien qu'éventuellement Sonos nous donne une explication un peu plus technique. La limitation survenant toujours lors de mises à jour de Sonos, l'odieux leur est automatiquement attribué, et c'est compréhensible!
Niveau d'utilisateur 5
Badge +3
Ce serait bien qu'éventuellement Sonos nous donne une explication un peu plus technique.

Bonjour,

Nous supportons effectivement au maximum les versions systèmes.

Android 4.2.2 est sortie le 11 Fevrier 2013 (soit 4 ans à ce jour), nous sommes actuellement à la version 8.1.
Le problème est bien au niveau des constructeurs qui en règle générale ne supporte pas plus 2 voir 3 ans au maximum les mises à jour sur leurs produits.

Je reprend comme toujours l'exemple de Windows XP dont le support est terminé depuis très longtemps via Microsoft et que nous avons supporté jusqu'à 2 ans supplémentaire.
Il en va de même pour Android, la version 4.2.2 est obsolète sachant que la version 4.3 est sortie au mois de juillet 2013 soit 5 mois à peine après la version 4.2.2.
Niveau d'utilisateur 5
Badge +3
Oui, j'avais bien compris tout ceci.

Quand je dis que ce serait bien d'avoir éventuellement une réponse un peu plus technique, ce n'est pas tout à fait ce que je voulais dire.
Niveau d'utilisateur 5
Badge +3
La raison technique est simple et en correlation avec le message.

1. L'application ne fait plus quelques Mo mais une centaine.
2. Les outils de developpement ne sont pas les mêmes, un "slide, boutton, etc ..." spécifique peut ne pas exister en version android 4.1 et commencer à partir de la version 5.0.
3. Si un problème est connu sur une version specifique non supporté nous ne pourrons rien y faire.
4. Cela induit de faire des versions spécifiques pour chaque système d'exploitation par exemple pour un menu, une animation, etc.

Par ailleurs, il s'agit aussi d'un % d'utilisateur, Android 4.2.2 represente moins de 4% dans le monde actuellement.

https://www.statista.com/statistics/271774/share-of-android-platforms-on-mobile-devices-with-android-os/
Niveau d'utilisateur 5
Badge +3
Bonjour Marc,

Donc, ce que je comprend est que chaque nouvelle version d'un système d'exploitation (Android, IOS et Windows) oblige Sonos à modifier ses applications, et que de continuer à supporter un vieux système d'exploitation entraîne automatiquement un poids supplémentaire à l'application, et j'imagine aussi une complexité supplémentaire pour les développeurs.

Sans compter, comme vous le signalez, le très faible taux d'utilisateurs des anciens systèmes d'exploitation.

Pour ma part ça répond.

Merci.
Bonjour,
Comme Emmanuel C qui a lancé le post, je fais partie de "l'élite" des 4% ayant encore Android 4.2.2.
J'avais cette tablette et elle fonctionnait très bien avec les versions précédentes de SOnos. Elle ne me servait d'ailleurs qu'à ça. Je peux contrôler mes produits Sonos avec mon PC ou mon téléphone, mais la tablette permettait à toute la famille de mettre de la musique dans la maison.
Je comprends les commentaires techniques concernant le fait de supporter les anciennes versions.
CEPENDANT, rien n'empêche une personne avec un ordinateur en XP de l'utiliser, sans support, sans toutes les nouvelles fonctionnalités. J'en attends de même de SONOS.
Je peux comprendre que les nouvelles versions de SONOS ne supportent pas les anciennes versions d'Android, mais POURQUOI empêcher d'utiliser le système comme il l'était en permettant de ré-installer la version antérieure qui fonctionnait très bien (ou si c'est possible : comment??) et en refusant la mise à jour?
Merci.
Niveau d'utilisateur 4
Badge +1
Bonjour ALC,

rien n'empêche une personne avec un ordinateur en XP de l'utiliser, sans support, sans toutes les nouvelles fonctionnalités.

Cette remarque est légitime, mais ce n’est pas tout à fait la même chose : Sonos est un système dans lequel différents appareils interagissent (contrôleurs et lecteurs). Il serait très difficile pour nous de gérer différentes versions cohabitant dans un même système, pour les raisons expliquées plus haut par Marc.
Vous pourriez ne pas faire les mises à jours (on ne peut par contre par revenir en arrière) mais vous seriez confronté à d’autre problèmes : lorsque le reste du système avance, le vôtre ne serait plus compatible, spécialement avec les services musicaux, vous. Vous ne profiteriez également pas de mise à jours de sécurité.
Bonjour,

Je me suis fait "avoir" avec un vieil Ipad, et maintenant avec une tablette Android qui ne me servait qu'à piloter Sonos...

Je comprends que le systeme Sonos évolue - C'est tout à fait normal.

Ce que je comprends moins malgré votre intervention ci-dessus, c'est pourquoi ne pas laisser le choix au client quitte à le mettre dans les problemes de securité dont vous parlez et limiter les fonctions au minimum accessibles à partir d'une vieille tablette ? Si on ne veut pas ajouter de nouveau service, comprenez bien que pour avancer, reculer une piste et choisir une musique dans une bibliotheque personnelle ou sur une radio internet qui existe depuis plus de 6 ans c'est cher payé !

Ce que je crains le plus , c'est qu'un jour Sonos nous dira : vous ne pouvez plus utiliser vos enceintes Sonos 3 ou 5 de première generation... sous couvert d'argument mémoire ou sécuritaire, etc, etc...

Enfin... tout cela est presque normal... avec le numérique on consomme et on jette...
Badge
Bonjour,

Comment puis-je mettre à niveau le SONOS sur mon Android 4.2.6? J'ai réussi à personnaliser le Widgetsoid sur mon Android et j'utilise également les programmes pour jouer à distance avec des animaux domestiques: les deux outils sont mis à jour avec succès. J'ai SONOS 8.0 mais j'aimerais mettre à jour SONOS 10.2.2

Accès via: https://fr.community.sonos.com/poser-une-question-228987/version-android-6766672
Badge
Bonjour,

Comment puis-je mettre à niveau le SONOS sur mon Android 4.2.6? J'ai réussi à personnaliser le Widgetsoid sur mon Android et j'utilise également les programmes pour jouer à distance avec des animaux domestiques: les deux outils sont mis à jour avec succès. J'ai SONOS 8.0 mais j'aimerais mettre à jour SONOS 10.2.2

Accès via: https://fr.community.sonos.com/question-228987/version-buyessays.cheap-android-6766672



Bonjour JeffStark,

J'ai également essayé de mettre à niveau et j'ai eu cette erreur: erreur 1013. J'ai suivi le guide ici: https://en.community.sonos.com/troubleshooting-228999/issues-with-10-2-and-now-in-a-loop-and-can-update-6826044

Commenter