Répondu

Obsolète et incompatibilité


J'ai un IPAD avec IOS 9.3.5 et j'ai la version de Sonis 9.2. Je ne peux plus utiliser mon Sonos, on m'indique que ma version est obsolète bien que la version IOS supérieure à 9.0 devrait fonctionner. Merci de m'aider
icon

Meilleure réponse par Yvain B 6 novembre 2018, 17:58

Bonjour BGQuébec.

L'application devrait effectivement fonctionner avec des options limitées sur votre iPad.
Ce problème se pose lorsque la liaison des produits au compte Sonos a été sautée/ignorée (cette association des produits au compte aurait du se faire 2-3 mises à jour en arrière).
Si vous avez la possibilité d'utiliser un appareil (tablette ou smartphone) fonctionnant sur une version logicielle supportée (à partir d'Android 5 ou iOS 10) vous pouvez faire cette étape depuis cet appareil, et l'application devrait ensuite fonctionner sur votre iPad.
Dans le cas contraire, nous pourrons vous aider en nous connectant à distance sur un ordinateur (PC ou Mac) si vous en avez un.
Ceci nécessitera que vous nous contactiez par téléphone (voir nos informations de contact ici).
Afficher l'original

22 Commentaires

Niveau d'utilisateur 6
Badge +2
Bonjour BGQuébec.

L'application devrait effectivement fonctionner avec des options limitées sur votre iPad.
Ce problème se pose lorsque la liaison des produits au compte Sonos a été sautée/ignorée (cette association des produits au compte aurait du se faire 2-3 mises à jour en arrière).
Si vous avez la possibilité d'utiliser un appareil (tablette ou smartphone) fonctionnant sur une version logicielle supportée (à partir d'Android 5 ou iOS 10) vous pouvez faire cette étape depuis cet appareil, et l'application devrait ensuite fonctionner sur votre iPad.
Dans le cas contraire, nous pourrons vous aider en nous connectant à distance sur un ordinateur (PC ou Mac) si vous en avez un.
Ceci nécessitera que vous nous contactiez par téléphone (voir nos informations de contact ici).
J'ai le même problème et je ne comprends pas la réponse d'Yvain B. Que dois je faire à partir de mon PC ou IPhone pour que Sonos fonctionne à nouveau sur mon IPad ?
Même problème pour moi et effectivement il faut dire que la réponse de Yvan B. est quelque peu confuse et incompréhensible.
Même problème avec mon IPad 2. Je fais comment maintenant pour accéder à mon Sonos et surtout recuperer ma licence Deezer qui va mourir dans cette boîte maintenant fermée pour mon IPad? Merci de répondre M. Sonos.
Bonjour,

Il faudrait que nous puissions réinstaller une ancienne version, 10.0.x
Cela sera t il possible?
Mon problème est identique, j'ai effectivement une autre tablette avec la mise à jour Ios 12.2 , mais je ne vois pas comment procéder pour ' Établir la liaison des produits au compte Sonos qui a été sautée/ignorée '.
Hello, il y a ~3sm J'avais réussi a installer une version de sonos sur mon ipad 2 IOS 9.3.5 (sonos v9.3.2) et tout fonctionnait correctement pour commander mes enceintes play:1, et maintenant, sans avoir fait de mise a jour spécifique, l'Ipad m'indique que mon systeme est obsolète et que l'ipad ne peut plus se connecter.
il n'y a eu aucun soucis sur Iphone ou android, mais ce sont des systeme plus recent qui support sonos v10.

Il y a t'il des mises a jours qui sont "poussées" automatiquement sur les enceintes ? je trouve très désagréable de perdre les l'usage de mon ipad comme télécommande.
Niveau d'utilisateur 6
Badge +2
Bonjour à vous.

Cette conversation date de Novembre 2018 : à l'époque les versions iOS 9 et Android 4.4 fonctionnaient encore en compatibilité limitée avec l'application Sonos.
Certains utilisateurs n'ayant pas validé l'enregistrement de leurs produits sous leur compte Sonos rencontraient alors ce problème.

Avec la mise à jour 10.1, ces versions ne sont aujourd'hui plus du tout compatibles avec Sonos.
Au moment du passage à la version 10 de Sonos, un message indiquant que ces versions ne seraient plus compatibles à partir de la mise à jour suivante ont été envoyés via email (pour les utilisateurs abonnés à notre Newsletter) et sur l'application elle même (dans la boite de réception).
Maintenir l'application sur des logiciels qui ne sont plus supportés par leur propre développeur constitue non seulement un coût pour Sonos, mais surtout un risque potentiel pour la sécurité des utilisateurs : l'application Sonos utilisée sur un logiciel ne bénéficiant plus de mises à jour de sécurité peut constituer une faille pouvant être exploitée pour un piratage.
J'ai reçu effectivement la même réponse de SONOS et avais reçu l'email mentionné sans oser y croire. Donc, en mot clé, on pourrait mettre "Comment SONOS crée de l'obsolescence programmée pour Apple". Belle solidarité entre entreprises au détriment des consommateurs et de la planète ? Comment se fait il que sur mon iPad avec iOS 9 seulement l'application SONOS ne fonctionne plus ? Toutes les autres applications seraient peu sérieuses et un danger pour mon système …. Difficile à croire. J'espère encore naïvement que quelqu'un chez SONOS va se rentre compte de cette aberration et proposer un patch etc... Ou alors il faudra en conclure que SONOS est un grand générateur d'obsolescence programmée et pourquoi pas nous réserve d'autres surprises de ce type sur ses propres appareils (idée pour le marketing produit de SONOS ) …. Dommage j'aimais bien l'esprit SONOS
Niveau d'utilisateur 6
Badge +2
Comment se fait il que sur mon iPad avec iOS 9 seulement l'application SONOS ne fonctionne plus ?
Certaines applications continuent en effet de fonctionner sous iOS.
D'autres avaient cessé d'être compatibles avec les iOS inférieures à 10 avant même Sonos, pour ne citer que trois exemples : Twitter, Spotify et Deezer.

Ou alors il faudra en conclure que SONOS est un grand générateur d'obsolescence programmée
Nous continuons d'assurer support et mises à jour sur des produits que nous avons sortis il y a plus de 10 ans (Play:5 1ere génération, Connect, Connect:Amp), il ne s'agit pas là d'une politique d'obsolescence programmée.
Notre politique est de ne pas continuer de maintenir l'application Sonos sur des plate-formes logicielles considérées comme obsolètes par leur propre concepteur.
Pourquoi ces concepteurs considèrent leurs propres logiciels commes obsolètes ? C'est à eux de répondre à cette question.
Bonjour, Deezer propose une version pour iOS 9 sur l'Apple store, je pense que votre affirmation est inexacte. De même Amazon Alexa fonctionne parfaitement sout iOS9. Donc c'est possible quand on le veut et toute l'origine de la situation n'est pas à rejeter sur Apple, SONOS a une large part de responsabilité. Il est encore heureux que vous assuriez les MAJ des HW conçus il y a 10 ans, mais dans le même temps vous ne proposez pas de solution alternatives, mêmes dégradées pour continuer à piloter ces HW alors que d'autres le font. Donc, soit SONOS ne veut pas investir sur ce sujet (garant pour lui d'une fidélité à long terme de sa base client), et vous l'avouez à demi-mot dans votre message ci-dessus que je cite "Maintenir l'application sur des logiciels qui ne sont plus supportés par leur propre développeur constitue non seulement un coût pour Sonos…." , soit SONOS ne sait pas comment faire 😞 , soit c'est une décision marketing en accord avec Apple 😞 etc... Donc SVP, arrêtez de reporter la cause du problème sur d'autres, ce qui arrive est la conséquence de vos décisions, il y avait plusieurs choix et SONOS a décidé consciemment de rendre son SW non compatible avec iOS9 pour…. je laisse les autres lecteurs des très nombreux forums à ce sujet terminer cette phrase
Niveau d'utilisateur 6
Badge +2
Les personnes qui avaient déjà téléchargé Deezer via l'AppStore peuvent en effet recharger la dernière version compatible avec iOS 9.
En revanche Deezer indique bien qu'une iOS 10 ou supérieure est requise pour installer l'application (un utilisateur sous iOS 9 qui n'aurait jamais téléchargé Deezer sur l'AppStore ne pourrait pas l'installer aujourd'hui par exemple).

Sonos combine une partie logicielle avec une partie hardware : les deux versions logicielles doivent correspondre pour pouvoir fonctionner.
Théoriquement, un système Sonos qui n'aurait pas été mis à jour vers la version 10, ni connecté à une application déjà sur cette version, continuerait à fonctionner en compatibilité limitée.
Concrètement cela est difficile à mettre en place puisqu'il faudrait rester sur un fonctionnement en vase clos dans lequel aucun appareil à jour ne devrait être associé au système (et ou bien entendu les mises à jour automatiques seraient désactivées dans les paramètres de l'application).
Sans compter qu'avec le temps, le système perdrait accès aux contenus en ligne.

Et en conclusion : non, nous ne cherchons pas à faire vendre des produits à Apple, pas plus qu'à Samsung, HTC ou Sony (puisque Android 4.4 n'est également plus compatible, comme iOS 9).
Sauf que SONOS rend obligatoire la mise à jour de son SW pour fonctionner (il y a peut être une option que je n'ai pas vue, mais elle n'est pas proposée dans le menu d'accueil quand le système SONOS ne veut pas se lancer du fait d'une demande de MAJ). Donc, SONOS oblige ses utilisateurs à rendre ses SW non compatibles avec l'IOS . Pourquoi ne proposez vous pas la même solution que Deezer qui laisse la possibilité aux anciens utilisateurs d'utiliser une version SW de Deezer pour iOS9 ? Pourquoi Amazon Alexa laisse également cette possibilité ?
Niveau d'utilisateur 6
Badge +2
Sauf que SONOS rend obligatoire la mise à jour de son SW pour fonctionner
Il est possible de désactiver les mises à jour automatiques via les paramètres de l'application Sonos.
Mais il suffit qu'un appareil ayant l'application à jour se connecte au système et lance la mise à jour qui lui sera demandée (puisque la version de l'application et celle du logiciel des appareils doivent correspondre) pour que vous ne puissiez ensuite plus vous connecter avec votre application non mise à jour (même chose si un appareil à jour et ajouté au système|).
Comme je vous l'indiquais plus haut : garder un système Sonos sur une version en ignorant les mises à jour est compliqué et nécessite un fonctionnement "en vase clos".

Pourquoi ne proposez vous pas la même solution que Deezer qui laisse la possibilité aux anciens utilisateurs d'utiliser une version SW de Deezer pour iOS9 ?
Pour les raisons déjà indiquées plus haut.
On en restera là dans cette discussion qui tourne en rond car vous n'avez pas d'autres solution que de me demander d'acheter une autre iPAD. Je reste très déçu que SONOS ne propose pas de solution à ses utilisateurs (clients ?) qui ont payé des milliers d'euros pour acheter des enceintes qui peuvent être rendues inutilisables d'un jour à l'autre du fait de SW non adapté /obsolète. Je n'ose pas imaginer ce qu'il se passerait si un constructeur de voiture par exemple faisait de même , pour pouvoir démarrer la voiture il faut racheter une nouvelle clé pour x ou y raison ….
Je suis dans le même cas avec mon ipad. Je trouve dommage de rendre une application inutilisable.
Je vais changer donc de maison du multiroom. Dommage
Badge
ca coutera moins cher d'acheter un iPad, genre le modèle 2017 ou 2018, pour moins de 200e ou moins de 300e.
j'ai du mal à accepter la façon de faire par Sonos, d'obliger les utilisateurs de renouveler leurs équipements
Badge
Ce n'est pas réellement la façon de faire de Sonos. Les nouvelles appli ne sont plus ou peu compatible avec les anciens IOS. ce n'est pas cool; mais c'est le fonctionnement des multi version d'ios (ou android) qui changent tout le temps.
il y a eu des paliers et deviennent des versions de bases !
Niveau d'utilisateur 5
Badge +3
Bonsoir,

en principe quand on achète un Iphone il faut tout racheter parce que plus rien n'est compatible.
Sonos prend encore en support 2 ans en plus que Apple en support.
Apple à déjà stopper de longtemps le support des vieux IOS.
Pourtant personne ne dis rien à Apple.
Moi depuis mon vieux MacBook pro de 2011 carte mère inutilisable pour un problème connu chez Apple de la carte graphique, je suis parti sur Windows 10 beaucoup mieux.
Vous n'avez plus d'update de sécurité personne ne dis rien non plus.

Sinon vous pouvez toujours utiliser Boot Camp pour avoir windows 10 sur votre mac...


Brian
"le logiciel sur ce périphérique est obsolète..."
J'ai aujourd'hui 2 ipad et une tablette android sur lesquels je ne peux plus utiliser l'appli sonos.
C'EST INADMISSIBLE.
A quand une version pour continuer à utiliser sonos sur les anciens appareils ?
Il faudrait toujours avoir la dernière version du système d'exploitation pour utiliser sonos ? C'est une grande arnaque !
Je ne pensais pas revenir sur ce forum (voir ci-dessus ), ayant le même pb de compatibilité SONOS / ancien IOS / IPAD et la même réponse IRRITANTE de l'équipe SONOS. Cependant, par le plus grand des hasards, je suis tombé sur l'application SONOSTUBE, dispo sur Apple store. Celle-ci est destinée à envoyer du contenu audio YOUTUBE sur un système SONOS. Et ça marche plutôt bien, installation rapide, assez intuitif d'utilisation . ET SURPRISE, SONOSTUBE s'installe et fonctionne complètement même sur mon ancien IPAD avec IOS 9.3.5 (et aussi avec les IOS les plus récents). SONOSTUBE tel que je l'utilise à ce stade ne permet que de passer du contenu YOUTUBE gratuit, ça fait déjà pas mal de musique, et SONOSTUBE doit être acheté 5 ou 6€ après deux jours (tj moins cher que de racheter un IPAD) . Mais je suis un débutant là, on doit pouvoir étendre à d'autres contenus.

Commenter